Access Manger 2 stopped working

  • 400 Views
  • Last Post 10 June 2020
spiner007 posted this 13 June 2019

I recently had an issue that my Access Manager 2 just stopped working. I've uninstalled and reinstalled a few times and when I try and launch the app I get the following error message pop up "Padding is invalid and cannot be removed". Nothing has changed on my Windows 10 PC when this issue just started happening. I looked at my Norton to see if the program all of a sudden got blocked but I don't see anything. That was the only thing I could think of. I saved off my accessmanager.xdb file so I could restore my passwords after reinstalling. I was very surprised that uninstalling and reinstalling a few times did not fix my issue. Help???

Attached Files

11 Comments
Order By: Standard | Newest | Votes
Admin posted this 03 July 2019

Hi spiner007,

You can follow the same instructions on this page to get Access Manager working again.
http://forum.accessmanager.co.uk/chat/i-get-the-error-index-outside-bounds-of-array-when-i-try-to-open-access-manager

Regards

spiner007 posted this 03 July 2019

Dear Admin, 

 

Thank you for the response. I just fixed my problem and thought I would share what I did in case this can help someone in the future. 

 

So regarding the error message in my original post, I can't say exactly why or what it is. Per the Admin comments I assume what you are saying is what was wrong. I am fairly familiar with the file structure as I worked through needing to recover my passwords in the past when reloading the software on a new computer. The passwords I've created are located in two files located in 'C:\'myusername'\AppData\Local\Citi-Software\AccessManager 2'. when I uninstalled the software I also needed to manually delete the folder Citi-Software in the above path. Uninstall would not delete this folder therefore when I reinstalled the software I continued to get the error in my initial post. Once deleting the folder I was able to reinstall the software and I could launch a clean version of Access Manager 2. Per instructions from an Admin in the past I copied my saved files before deleting and reinstalling the software called AccessManager dot cfg and dot xbd. 

 

Once I did this I got the same error message as in my original post. I thought my password file must be corrupt and my passwords were lost. And in fact they were corrupt, sort of. Turns out I believe the actuall file that holds the password data is the AccessManager.xbd. The dot cfg file must just be a static file that doesn't get written to. On a hunch I tried only replacing my original dot xbd file and using the dot cfg file from the new install. Once I did that the program was able to launch and all my passwords were intact. 

 

I hope this is usefull to someone at some point. I would be happy to answer anyones questions in the future if they have the same or similar problem. 

Pool Cleaner posted this 18 March 2020 - Last edited 18 March 2020

I'm glad to see you got your problem fixed!  We do our best to help people fix their pool problems every day.  We even install new pool lighting as well to give your pool that special mood you're looking for and add safety at night.

saeed25180 posted this 17 May 2020

accounting services Kent

AndreiP posted this 22 May 2020

I really appreciate that you made that turn around. Thanks for sharing the knowledge on how to fix the issue. I just copied and pasted your recent comment about the instructions just in case I encounter this issue when I upgrade my OS to windows 10. By the way, do you have plans to renew your garage flooring? Try this Boulder, Texas, garage epoxy flooring this might help you out. 

horeakaii posted this 22 May 2020

Thank you spiner007! You're a life saver!

 

St Pete SEO

LucilleM posted this 28 May 2020

Thanks, mate! I often experience that problem too!

https://pathogenx.com/ Real Estate Specialists Miami

Chris889 posted this 28 May 2020

It didnt work too after I updated it and reinstalled. Yours is a much easier way I think.

https://www.landscapingservicescolumbia.com carpet cleaning companies

diplo888 posted this 28 May 2020 - Last edited 28 May 2020

Nice one admin, I never thought that admin can reply that fast. Nice job. Event services  Event management

Danielperez123 posted this 09 June 2020

Spiner 007 is great! I really love it. Thanks | Thrust Electric Bikes

lesternelson51340 posted this 10 June 2020

I think what we did was delete the AccessManager.cfg and/or the AccessManager.config file. commercial property for lease Cincinnati